解决微信小程序sdk在升级到php7.1后的一个问题

升级php7.1以后,来自微信官方的小程序解密代码会提示:

mcrypt_module_close deprecated

意思就是php7.1-mcrypt已经即将废弃了,不推荐使用了。

解决的办法:

1. 使用替代库:composer require phpseclib/mcrypt_compat

2. 同时删除原来的php7.1-mcrypt:apt remove php7.1-mcrypt,不删除会继续报错。